SHOP BY CATEGORIES

300Mbps Wireless N USB VDSL/ADSL Modem Router

SKU TD-W9970 Category Brand:

£44.40 Incl. VAT
£37.00 Excl. VAT

2 in stock

Description

  • Versatile Connectivity –With DSL and LAN/WAN ports, TD-W9970 is fully compatible with the VDSL2/ADSL2+/ADSL2/ADSL standards and also works with fibre/cable access.
  • Boosted Speeds –Superfast VDSL broadband speeds of up to 100Mbps together with 300Mbps Wi-Fi.
  • Maximized Range –Powerful external antennas provide far-reaching wireless coverage in every direction.
  • TP-Link Tether App – Easily access and manage your network, including remote control and automatic updates, using any iOS or Android mobile device.

The latest VDSL2 technology allows the TD-W9970 to deliver impressive VDSL broadband speeds of up to 100Mbps, which is almost 4 times faster than ADSL2+. The integrated DSL port supports all standard DSL connections* for compatibility with most ISPs. The TD-W9970 serves as a DSL modem and wireless router, combining two devices in one.

The TD-W9970 is built to connect you to the internet, no matter your situation. The Ethernet WAN port supports wired connection to cable or fibre modem, letting you take full charge of its wireless capabilities as a router. In case your internet goes down, attach a 3/4G adapter to USB 2.0 port to serve as a backup option so you can get back online in no time.

Set up the TD-W9970 in minutes thanks to its intuitive web interface and the powerful Tether app. Manage network settings, including Parental Controls and Access Control, from any Android or iOS device. Tether also provides Automatic Firmware Updates to always give your network the latest performance and security.

HARDWARE FEATURES
Interface 1× 10/100 Mbps LAN/WAN Port, 3× 10/100 Mbps LAN ports, 1×
RJ11 port, 1× USB 2.0 Port
Ports 1× 10/100 Mbps LAN/WAN Port, 3× 10/100 Mbps LAN ports, 1×
RJ11 port, 1× USB 2.0 Port
Button WPS/Reset Button, Wi-Fi Button, Power On/Off Button
External Power Supply 9V/0.85A
IEEE Standards IEEE 802.3, 802.3u
VDSL2 Standards ITU-T G.993.2, ITU-T G.993.5 (G.vector), ITU-T
G.998.4 (G.INP)
ADSL Standards Full-rate ANSI T1.413 Issue 2, ITU-T G.992.1(G.DMT),
ITU-T G.994.1 (G.hs), ITU-T G.995.1
ADSL2 Standards ITU-T G.992.3 (G.DMT.bis)
ADSL2+ Standards ITU-T G.992.5
Dimensions ( W x D x H ) 7.7 × 5.1 × 1.4 in. (195 × 130 × 36 mm)
Antenna 2 × 4dBi Fixed Omni-Directional Antennas
WIRELESS FEATURES
Wireless Standards IEEE 802.11b/g/n 2.4GHz
Wireless Speeds 300 Mbps at 2.4 GHz
Frequency 2.400 – 2.4835 GHz
Signal Rate 300 Mbps at 2.4 GHz
Transmit Power <20dBm(EIRP)
Wireless Functions Enable/Disable Wireless Radio, WMM,
Wireless Statistics
Wireless Security Supports 64/128-bit WEP, WPA/WPA2,
WPA-PSK/WPA2-PSK encryptions
SOFTWARE FEATURES
Quality of Service WMM, Bandwidth Control
Security Firewall & Dos Protection, Service Filtering, Access Control, IP &
MAC Binding, IPv6 Firewall
Operating Modes DSL Modem Router, 3G/4G Router, Wireless Router
Management Remote management,
Telnet management,
Command Line Interface,
SSL for TR-069,
SNMP V1/V2C,
Web-Based Firmware Upgrade,
CWMP(TR-069),
Diagnostic Tools
DHCP Server, Client, DHCP Client List, Address Reservation, DHCP Relay
Port Forwarding Virtual Server, Port Triggering, UPnP, DMZ, Manage Control
Dynamic DNS DynDns, NO-IP
VPN Pass-Through PPTP, L2TP, IPSec Pass-through
Protocols Supports IPv4 and IPv6
ATM/PPP Protocols ATM Forum UNI3.1/4.0,
PPP over ATM (RFC 2364),
PPP over Ethernet (RFC2516),
IPoA (RFC1577/2225),
PVC – Up to 8 PVCs
Guest Network 2.4 GHz Guest Network
IPSec VPN Supports up to 10 IPSec VPN tunnels
OTHERS
Certification CE, RoHS
Package Contents DSL Modem Router TD-W9970
External DSL Splitter
RJ11 DSL Cable
RJ45 Ethernet Cable
Quick Installation Guide
Power Adapter
System Requirements Windows 10/8.1/8/7/Vista/XP or Mac OS or Linux-based operating
system
Environment Operating Temperature: 0℃~40℃ (32℉ ~104℉)
Storage Temperature: -40℃~70℃ (-40℉ ~158℉)
Operating Humidity: 10%~90% non-condensing
Storage Humidity: 5%~90% non-condensing

Related Products